Bryan Research & Engineering, Inc.   Contact Us  |  Register   |  Login    
     
 

Powerful Process Simulation Technology           
ProMax®
                                                       Unparalleled Customer Service

 
    Thursday, December 18, 2014   ProMax FAQ   Search   

Frequently Asked Questions (FAQs)

Common Error Conditions and Messages

1. What causes error 80040154, "Class Not Registered"?

If this error occurs during startup, the likely reason is Microsoft Visio is not installed on the system or the system does not meet minimum version requirements for Visio. ProMax supports Visio 2002/2003/2007 Professional or Standard. See the ProMax release notes for further information and requirements concerning service packs and hotfixes. Ensure that Visio will run without error outside of ProMax before attempting to start ProMax.

If this error occurs during execution of a ProMax solver or specifier, it is likely that your computer is missing the Microsoft Windows script control or other scripting components. Normally, these components are bundled with the operating system for Windows, however some software will remove these components when the software is removed from the computer. For these systems the scripting control will require manual reinstallation.

Please contact BR&E Support if you need assistance with this error.

2. I am receiving a "Compile error in hidden module" message or "Microsoft Forms - Could not load some objects..." while using ProMax, how can I correct this?

This error is typically caused by a Windows Update that either replaces the MSCOMCTL.OCX with a previous version, or unregisters the current MSCOMCTL.OCX file used by ProMax for some tools, such as Property Stencils and Scenario Tool. This is a known bug with the latest Microsoft Common Controls; some more information on this issue is outlined on Microsoft's site at: http://support.microsoft.com/kb/2597986

To check your version:

  1. Navigate to the appropriate folder:
    • For a 64-bit OS, type: %WINDIR%\sysWOW64
    • For a 32-bit OS, type: %WINDIR%\system32
  2. In the folder that opens, find the file MSCOMCTL.OCX
  3. Right-click on the file, and select “Properties”
  4. Go to the “Details” tab (“Versions” tab in Windows XP)
  5. Find the File Version; the current version should be 6.1.98.34 or later

If the file on your computer is an earlier version, please contact Support and let them know your MSCOMCTL.OCX file is out-of-date. 

To register the required file, please follow the procedure listed below.  For your convenience, we have created a script file that will follow these steps for you.  The script is located here.  Administrative privileges are required for the process whether utilizing our script tool, or manually following this procedure. 

  1. Close ProMax and any Microsoft Office files that are open.
  2. Go to the Start Menu or Windows button in the lower left-hand side of your desktop, select “All Programs” > “Accessories”. Right-click on the “Command Prompt” and select “Run as Administrator”. Note: this typically needs to be done even if you are logged in as administrator on the computer.
  3. At the command prompt, type the following to navigate to the appropriate folder:
    • For a 64-bit OS, type: cd %WINDIR%\sysWOW64
    • For a 32-bit OS, type: cd %WINDIR%\system32
  4. For either version, type (or copy/paste) the following command:
    regsvr32 mscomctl.ocx
  5. You should get a message indication if this is successful
  6. Attempt to navigate to the Users folder by typing the following into the command prompt:
    cd %USERPROFILE%
  7. If this folder exists, type the following:
    del /S /A:H /A:-H *.EXD
  8. If successful, you should see a list of deleted files
  9. Close the command prompt window and try using ProMax again
3. What causes an error message stating that Visio is not installed or improperly installed?

Check that Visio will run independently of ProMax, and that the Visio license is valid. If not, please correct this issue first.

Currently only Visio 32-bit is supported; if the 64-bit version was installed please uninstall the 64-bit version and then install the 32-bit version. Support for the 64-bit version will become available beginning with ProMax 4.0.

If the above issues do not apply, and your version of Visio is different that the version of Office installed on the system, the installation order may have been incorrect. It is necessary to follow Microsoft's specified installation order, meaning that earlier-year products must be installed before the later-year products. Please see Microsoft's Support site http://support.microsoft.com/kb/2784668 for more information. Install dates can be found from Control Panel ->Program and Features.

An incorrect installation order can only be resolved by uninstalling the offending programs and reinstalling them in the correct order. We recommend using a consistent version of Visio and Office.

4. Why does the ProMax "splash screen" appear, but fail to continue to open the program?

This behavior typically appears after Visio or ProMax crashed unexpectedly on the system previously. To open ProMax:

  1. Close all ProMax and Visio instances that are currently running.
  2. Open the Task Manager either by right-clicking on the toolbar and selecting "Start Task Manager", or by pressing Ctl-Alt-Del and selecting "Start Task Manager".
  3. Select the Processes tab within the Task Manager, and have Windows "End Process" for any ProMax.exe or Visio.exe tasks that appear.
  4. Open Visio (not ProMax), and Select the "File" menu
  5. Select "Options" and then "Add-Ins" from the dialog that opens.
  6. At the bottom of the screen, change the Manage option from "COM Add-ins" to "Disabled Items" and select "Go".
  7. If ProMax Toolbar is listed, select it and press "Enable".
  8. Close Visio and try ProMax again.
5. How can I check that I have the most up-to-date version of ProMax?

ProMax installs the BR&E Notification Manager program by default onto your system which will alert you to any program updates. To see if there are any currently available for your system, from your Start Menu->All Program Files->Bryan Research & Engineering->ProMax folder, select the Notification Manager. If it is not found here, browse to your C:\Program Files (x86)\Bryan Research & Engineering Inc\ProMax3\ folder, and look for the NotificationManager.exe file. When you run this executable, previous messages may have been dismissed or postponed; select the "Reset Dismissed" or "Reset Postponed" options to see if any notifications are available.

6. What causes Visual Basic System Error "ClassFactory cannot supply requested class. System Error &H80040111", and ProMax "Error number: 800AC472"? Other error may appear as well, such as "Compile error in hidden module: Navigator", or "Visual Basic out of memory".

This error is typically caused by a Windows Update that either replaces the MSCOMCTL.OCX with a previous version, or unregisters the current MSCOMCTL.OCX file used by ProMax for Property Stencils, Scenario Tool, etc...

To check your version:

  1. Navigate to the appropriate folder:
    • For a 64-bit OS, type: %WINDIR%\sysWOW64
    • For a 32-bit OS, type: %WINDIR%\system32
  2. In the folder that opens, find the file MSCOMCTL.OCX
  3. Right-click on the file, and select “Properties”
  4. Go to the “Details” tab (“Versions” tab in Windows XP)
  5. Find the File Version; the current version should be 6.1.98.34 or later

If the file on your computer is an earlier version, please contact Support and let them know your MSCOMCTL.OCX file is out-of-date.  If the version on your computer is current, let our Support staff know when you contact us.

To register the required file, please follow the procedure listed below.  For your convenience, we have created a script file that will follow these steps for you.  The script is located here.  Administrative privileges are required for the process whether utilizing our script tool, or manually following this procedure.  This is a known bug with the latest Microsoft Common Controls; some more information on this issue is outlined on Microsoft's site at :  http://support.microsoft.com/kb/2597986

  1. Close ProMax and any Microsoft Office files that are open.
  2. Go to the Start Menu or Windows button in the lower left-hand side of your desktop, select “All Programs” > “Accessories”. Right-click on the “Command Prompt” and select “Run as Administrator”. Note: this typically needs to be done even if you are logged in as administrator on the computer.
  3. At the command prompt, type the following to navigate to the appropriate folder:
    • For a 64-bit OS, type: cd %WINDIR%\sysWOW64
    • For a 32-bit OS, type: cd %WINDIR%\system32
  4. For either version, type (or copy/paste) the following command:
    regsvr32 mscomctl.ocx
  5. You should get a message indication if this is successful
  6. Attempt to navigate to the Users folder by typing the following into the command prompt:
    cd %USERPROFILE%
  7. If this folder exists, type the following:
    del /S /A:H /A:-H *.EXD
  8. If successful, you should see a list of deleted files
  9. Close the command prompt window and try using ProMax again

SQL Server Installation Issues and Errors

7. How do I fix the error "SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF] or "Could not open a connection to SQL Server"?

This problem is often due to a timeout that occurs between ProMax and its internal database. To remedy this problem, first reboot your computer and try ProMax again. If the problem persists, increase the default timeout for this process. BR&E has created a VBScript program that can be used to increase the timeout. Simply download the program from our website here and execute it using an account with administrative privileges. A message box will be displayed once the timeout has been successfully increased. By default, the timeout will be changed to 60 seconds. This value can be changed using a “/timeout:” command line option if required.

8. My antivirus software indicates a Trojan horse in the ProMax distribution DVD. Do I need to be concerned?

Unfortunately, several common antivirus programs over aggressively indicate a false positive for viruses, especially in the file reg2.exe. This program is supplied by a third-party vendor, and the application is of the type that can frequently cause this false indication. Two antivirus programs that we are familiar with that may indicate this false positive are AVG and ZoneAlarm. Our supplier is working with these (and other) antivirus vendors to white-list these files so they are not falsely flagged in the future. In order to install and run ProMax, you will need to disable virus scanning on this particular file. You also will likely need to disable the antivirus program on the reg2.exe file in the %ProgramFiles%\Bryan Research & Engineering Inc\ProMax3 folder after the installation is completed to prevent the antivirus software from relocating the file to its quarantine folder.

9. I receive a message that the ProMax password for SQL installation is not secure enough, how can I change this password?

In order to specify an alternate SA account initial password, SQL Express must be installed separately from ProMax. If the SQL instance is installed with the setup.exe application, the default BryanRes1 password will be set in the SQL instance.

SQL Express Installation

To install SQL express, obtain the install package from the ProMax DVD in the ISSetupPrerequisites folder, or from the Microsoft download site, http://download.microsoft.com. ProMax is compatible with SQL Express 2005, 2008, and 2008 R2. If downloading from Microsoft, you should get the latest service pack release of the software. All x86 versions of ProMax should be installed with an x86 version of SQL Express regardless of the operating system architecture.

To install SQL Express 2005 (SP4 recommended), use the following command line:
SQLEXPR.exe /qb ADDLOCAL=SQL_Engine,SQL_Data_Files,Client_Components,Connectivity INSTANCENAME=BRYANRES SECURITYMODE=SQL SAPWD=BryanRes1 DISABLENETWORKPROTOCOLS=1 ENABLERANU=0

To install SQL Express 2008 (SP3 recommended), use the following command line:
SQLEXPR_x86_ENU.exe /QS /ACTION=Install /FEATURES=SQLEngine,Conn /INSTANCENAME=BRYANRES /SECURITYMODE=SQL /SAPWD=BryanRes1 /SQLSVCACCOUNT="NT AUTHORITY\Network Service" /SQLSYSADMINACCOUNTS="NT AUTHORITY\Network Service" /ENABLERANU=0

To install SQL Express 2008 R2 (SP2 recommended), use the following command line:
SQLEXPR_x86_ENU.exe /QS /ACTION=Install /IACCEPTSQLSERVERLICENSETERMS=1 /FEATURES=SQLEngine,Conn /INSTANCENAME=BRYANRES /SECURITYMODE=SQL /SAPWD=BryanRes1 /SQLSVCACCOUNT="NT AUTHORITY\Network Service" /SQLSYSADMINACCOUNTS="NT AUTHORITY\Network Service" /ENABLERANU=0

To install SQL Express 2012 (SP1 recommended), use the following command line (SQL Express 2012 is only compatible with ProMax 3.2.13116 and later):
SQLEXPR_x86_ENU.exe /QS /HIDECONSOLE /UPDATEENABLED=FALSE /SkipRules=RebootRequiredCheck /ACTION=Install /IACCEPTSQLSERVERLICENSETERMS=1 /FEATURES=SQLEngine,Conn /INSTANCENAME=BRYANRES /SECURITYMODE=SQL /SAPWD=BryanRes1 /ENABLERANU=0

In the above commands, you should replace the BryanRes1 value for the SAPWD parameter with the password required by your specific requirements. Additionally, you should select the language of SQL Express that is appropriate for your locale based on recommendations by Microsoft. In the above examples, ENU stands for English.

The SQL Express instance can be installed using the GUI rather than the command line if desired. The GUI is invoked by simply double clicking the installation package in Windows Explorer. However, if the GUI is selected, you must be certain that the options selected in the installation process match those specified in the command lines above. For further assistance on SQL installation, please contact our support group.

ProMax Installation

Once SQL Express is installed with the required password, ProMax must be installed. The ProMax installation package contains a public Windows Installer property called SAPWD. The alternate password is specified through this public property. To install ProMax using the setup.exe program on the DVD, issue the following command (replacing the password with your password):
   d:\setup.exe /V"SAPWD=BryanRes1"
assuming the installer is present in drive D:. This command does not install SQL Express with the indicated password. It only indicates to the ProMax installer what the SA password is for SQL Express. If you do not first install SQL Express with one of the above methods, the ProMax installation will fail due to an unexpected password.

If all prerequisite software has been installed, you can install ProMax directly from the Windows Installer database (msi). To install from the MSI file, use the following command (again replacing the password with your value):
   msiexec /i d:\ProMax.msi SAPWD=BryanRes1
The above command assumes the ProMax database file is on drive D:.

Other more complicated installation scenarios are possible depending on your requirement and environment. If the installation package is installed through Active Directory Group Policy Objects (GPO) or some other similar technique, a Windows Installer transform may need to be created to set this property. Please contact our support group if you need assistance in these environments.

10. How do I fix the error "...The FILESIZE property is incorrect."?

First, try rebooting the system. If the error persists after reboot:

  1. If you have a Lenovo computer with "RapidBoot" enabled, please uninstall RapidBoot from the ProgramFiles\Lenovo\RapidBoot folder and running the uninstall executable. After uninstalling Rapidboot, uninstall ProMax and the BRYANRES SQL Express instance, reboot, and reinstall ProMax.
  2. If step 1 does not apply, Run Services.msc (type "services.msc" at Start->Run in XP, or type "services.msc" in the Search box in Windows 7).
  3. Find SQL Server (BRYANRES) in the list and right-click, select "Stop" from the menu.
  4. Get new secservr.exe file from here.
  5. In the Services (step 2) right-click on SQL Server (BRYANRES) and select "Properties". In the dialog, look at the "Path to executable:" which is where the file will be located, usually something like: C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\secservr.exe (You may need to supply admin password to access this location).
  6. Replace secservr.exe with the one you obtained in item 3.
  7. In the Services, right-click on SQL Server (BRYANRES) and select "Start" from the menu.
  8. Try ProMax again.
  9. If the issue persists, uninstall ProMax and the BRYANRES SQL Express Instance. Reboot, and reinstall ProMax.

Security Device Issues

11. How do I activate or update my HASP key?

ProMax installs the BR&E Licensing Wizard program by default onto your system which will be used to activate and update your security device. This program is available from your Start Menu->All Program Files->Bryan Research & Engineering->ProMax folder. If it is not found here, browse to your C:\Program Files (x86)\Bryan Research & Engineering Inc\ProMax3\ folder, and look for the LicensingWizard.exe file. If this is not available, please see FAQ #15 on this page.

Follow the instructions from the first option "Perform initial activation of a Sentinel key" if this an initial activation of a newly acquired security device.

Follow the instructions from the second option "Apply an update or cancellation to a Sentinel Key" if this an update you have been instructed to perform on your security device.

12. How do I find the security device number?

If your security device is a hardware USB device, please look for a 4 or 5 digit number engraved in the side of the plastic. If you have a software key we generally will not need the number. Our support staff can assist you if you have any questions or concerns.

13. How do I solve security violation 382/1/31?

The error indicates that the security device has not been activated or the program is unable to find the USB dongle (HASP) device.

If you have not activated the security device, please follow the instructions found in FAQ #11. If you have already activated the security device, see the following steps to have it recognized on your system.

For a Local PC Security Device:

  1. Verify that the key is firmly connected into a USB port, and that the light on the device is glowing.

    Note: If it was attached during the installation process of ProMax, please remove the device and insert it in a different USB port. The computer should then indicate that new hardware has been found and that it is loading the required device drivers. Once the computer states that the hardware is available for use, you should be able to use ProMax.

  2. Verify that the Sentinel device driver is installed on your computer. The simple way to check is to navigate to http://localhost:1947 on your computer. If you can successfully open the web-based application called the Sentinel Admin Control Center, then the driver is installed.

    If the device driver is NOT installed, then you can find this on the ProMax DVD by following the path: “Sentinel Key” -> “Driver” -> “GUI”. The file is titled HASPUserSetup.exe. Install this file on your computer. Note: This file can also be found at http://sentinelcustomer.safenet-inc.com/sentineldownloads; it is titled “Sentinel HASP/LDK Run-time Setup”. As of 2/18/2014 the version is 6.60.

For a Network Security Device:

If using a network device the DNS name or IP address of the license server must be obtained from the IT department, then follow these steps:

Client-side (the computer that ProMax is being used on):

  1. Verify that the Sentinel device driver is installed on your computer. The simple way to check is to navigate to http://localhost:1947 on your computer. If you can successfully open the web-based application called the Sentinel Admin Control Center, then the driver is installed.

    If the device driver is NOT installed, then you can find this on the ProMax DVD by following the path: “Sentinel Key” -> “Driver” -> “GUI”. The file is titled HASPUserSetup.exe. Install this file on the computer. Note: this file can also be found at http://sentinelcustomer.safenet-inc.com/sentineldownloads; it is titled “Sentinel HASP/LDK Run-time Setup”. As of 2/18/2014 the version is 6.60.

  2. After the driver is installed most computers require some configuration to point your computer to the location of the server. Verify that this configuration has been completed.
    1. To access the configuration section, open your web browser and navigate to the location http://localhost:1947.
    2. Click Configuration under Administrative Options followed by the Access to Remote License Managers tab. On that page, use the Specify Search Parameters to enter either the IP address or the hostname of the system with the network key.
    3. Occasionally selecting “Aggressive Search” is necessary to successfully find the network key.
    4. If the network key is accessible via broadcast (as determined/set by your IT department), the above steps may not be required.
    5. Multiple locations may be specified by placing entries on separate lines. This will be required if separate systems are used to host HASP protected applications from different vendors. Separate host systems are not required with different applications as any number of keys can be attached to a single host.
    6. By default, only local administration of the Sentinel Runtime Environment is permitted. This can be changed on the Basic Settings tab. For more information concerning the Sentinel Admin Control Center, select the help links on the appropriate page.'

Server-side (typically performed by an IT department):

  1. The server used may be any system in your network with a static IP address or hostname resolvable by DNS that is accessible by the workstations that will run ProMax.

  2. The Sentinel LDK Runtime Environment must be installed. The simple way to check whether this is already installed is to navigate to http://localhost:1947 on the server. If the web-based application called the Sentinel Admin Control Center can be opened, then the driver is installed.

    If the device driver is not installed, it can be found on the ProMax DVD by following the path: “Sentinel Key” -> “Driver”.

    The “GUI” folder may be selected for a hardware key installation; the file is titled HASPUserSetup.exe. Install this file on your computer.

    Note: this file can also be found at http://sentinelcustomer.safenet-inc.com/sentineldownloads; it is titled “Sentinel HASP/LDK Run-time Setup”. As of 2/18/2014 the version is 6.60.

    The “CmdLine” folder must be selected for an installation where a software key will be used, and may also be used for a hardware key. The command line bre.haspdinst.exe option will install the LDK run-time and a vendor token that will allow application of software keys from network license servers where ProMax is not installed. The haspdinst.exe option will install only the LDK run-time and may be used for a hardware key installation, but not a software key environment.

    Note: the non-vendor specific version of this file may be found at http://sentinelcustomer.safenet-inc.com/sentineldownloads; it is titled “Sentinel HASP/LDK Run-time Command Line”. As of 2/18/2014 the version is 6.60.

  3. Verify that the NetHASP dongle is securely seated in a USB port on the server and the light is on.

    Note: If it was inserted while you were installing, please remove it and place it in a different USB port. The computer should signal that it has found new hardware and is configuring to use it. Once the light on the key is back on, it should be available for use again.
14. How do I solve security violation 382/1/33?

The 'Sentinel Local License Manager' service is not running on the computer.

Open the Windows Services Management Console. In Windows XP, select the Start button, then from the Run... prompt type 'services.msc'. In Windows 7, select the Start button, then in the 'search files and folders' box type 'services.msc', and then right-click and 'Run as administrator'.

Look for the Sentinel Local License Manager and its status. If it is not started, right-click and select 'start'. If it is started, right-click and select 'restart'.

If it gives an error or will not start, attempt rebooting the system to see if it will open after reloading. If it still will not start, the Windows firewall and/or anti-virus software could be blocking the port necessary for the driver to function. Port 1947 should be excluded from any firewall blocking for both TCP and UDP access. After opening the port the system should be rebooted.

Licensing Wizard Issues

15. I don't see the Licensing Wizard in my ProMax folder from the Start menu; where can I find it?

In several scenarios the Licensing Wizard will need to be added to the computer separately from the ProMax installation. This may be accomplished by the following steps:

  1. Open the “Programs and Features” list (called “Add/Remove Programs” list in Windows XP). This can typically be found from the Start Menu > Control Panel.
  2. Find BR&E ProMax from the list.
  3. Select "Change".
  4. From the BR&E Installation screen that appears, select “Next”, followed by “Modify” on the next screen.
  5. Scroll down in the list of options and find “BR&E Licensing Wizard” from the list. Click on the icon next to it, and change it to “This feature will be installed on local hard drive.”
  6. Select “Next” and finish the installation. The Licensing Wizard should now be available to use on the computer.
16. I receive a "The remote server returned an unexpected response: (407) Proxy Authentication Required." error after pressing the "Submit Activation Data" button in the Licensing Wizard. How can I fix this?

This error appears to be related to internet proxy configurations interfering with communication with our server. The best solution is to have you or your IT staff add a rule to your corporate firewall and proxy server to place "https://secure.bre.com" to your "white list". You should then attempt to browse in Internet Explorer to the same site https://secure.bre.com. Once verifying that you can access the site, please try the Licensing Wizard again. (Note: you do not need to perform any steps on the secure website you just accessed).

In some situations, you may be able to run the Licensing Wizard successfully after downloading this file and then perform the following steps:

  1. Close the Licensing Wizard if it is still open.
  2. Browse to the location of the Licensing Wizard on your computer (typically C:\Program Files (x86)\Bryan Research & Engineering Inc\ProMax3).
  3. Rename the file "LicensingWizard.exe.config" to "LicensingWizard.exe.config.old".
  4. Rename the file "NotificationManager.exe.config" to "NotificationManager.exe.config.old".
  5. Unzip and then copy the downloaded file into the same folder.
  6. Try running the wizard again.

A work-around to this issue is to have you or your IT staff activate the key on a system that is not in your network and has standard internet access without a proxy server. This may be done directly from the DVD using the Licensing Wizard found in the “Sentinel Key” folder. If for some reason the computer used to activate the key does not have the Microsoft .Net Framework Client Profile or the Microsoft VC++ redistributables on the system, an error might appear when attempting to launch the wizard. The .Net Framework is probably installed as it is part of the Microsoft update process. The VC++ redistributables are on the DVD in the Sentinel Key > Licensing Wizard folder.

17. I receive a "The remote server returned an unexpected response: (417) Expectation failed." error after pressing the Submit Activation Data" button in the Licensing Wizard. How can I fix this?

This error can typically be fixed by using a slightly modified configuration file for the Licensing Wizard. Please download this file and then perform the following steps:

  1. Close the Licensing Wizard if it is still open
  2. Browse to the location of the Licensing Wizard on your computer (typically C:\Program Files (x86)\Bryan Research & Engineering Inc\ProMax3).
  3. Rename the file "LicensingWizard.exe.config" to "LicensingWizard.exe.config.old".
  4. Rename the file "NotificationManager.exe.config" to "NotificationManager.exe.config.old".
  5. Unzip and then copy the downloaded file into the same folder.
  6. Try running the wizard again.
18. I receive a "The program can't start because mfc100u.dll is missing from your computer. Try reinstalling the program to fix this problem." error when attempting to start the Licensing Wizard. How can I fix this?

This is most likely caused by missing VC++ redistributables on the system. These files are located on the ProMax DVD in the Sentinel Key>Licensing Wizard folder in a file named vcredist_x86.exe. This is a self-executing file, so that once double-clicked the appropriate installation should begin if the user has appropriate installation privileges.

19. Does the Licensing Wizard have to be installed on every computer within my company?

In general, no it doesn’t – the Licensing Wizard is not required for using ProMax with the security device. For a hardware security device (the USB device) the Licensing Wizard only needs to be placed on the computer you have selected to activate or update the device. Once the device has been activated, the Licensing Wizard is no longer required unless another update needs to occur. However, for a software key, the Licensing Wizard must be run from the system that will be using ProMax. Additionally, if a computer will be utilizing detachable software licenses from a networked environment, the Licensing Wizard should be available for the license detachment on the client machine.

System Requirements and Compatibility

20. What are the minimum operating system requirements?

ProMax will run on Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows 8 operating systems (note, support for Windows XP is ending from Microsoft on April 8, 2014 and we will likewise end support at this time). ProMax requires 1 GB of memory. Please visit Microsoft Support for information on system requirements for Visio and Office. ProMax operates on both 32-bit and 64-bit versions of Windows.

21. What versions of Microsoft Visio are supported?

ProMax is compatible with both Professional and Standard editions of Visio 2003, Visio 2007, Visio 2010, and Visio 2013. Visio 2010 and later is only compatible with ProMax 3.2 and later. Visio 2013 is only compatible with ProMax 3.2.13116 and later. Currently ProMax supports 32-bit versions of Visio only; future releases will support 64-bit versions. Please see ProMax Release Notes for more complete and specific information on service pack and hotfix requirements.

22. What versions of Microsoft Excel work with ProMax

ProMax has been tested with Excel versions 2003 and later. We generally recommend using the same version of Office products as the Visio that will be used with ProMax. If different versions will be used, please install the older software first. Currently ProMax supports 32-bit versions of Office only; future releases will support 64-bit versions as well. Additional information can be found in FAQ #3 on this page.

23. Does ProMax run using Microsoft Terminal Services?

Yes, ProMax has been tested with Windows 2000 Server and Windows 2003 Server Terminal Services. Using ProMax with Terminal Services requires a network license for ProMax.

ProMax Configuration and Customization

24. What are some of the common configuration changes I can make in Options.xml?
  1. Change the default content and order of stream properties displayed and reported by ProMax.
  2. Change the default composition bases displayed and reported for a stream by ProMax.
  3. Change the properties that are displayed in heat exchanger and distillation column internals.
  4. Change the properties that are displayed in process stream properties tooltips.
  5. Change the default display and reporting precision.
  6. Change the default unit set for newly created projects.
  7. Change the default gauge pressure setting for newly created projects.
  8. Change the default percent/fraction setting for newly created projects.
  9. Add user defined unit sets.
  10. Change the default atmospheric pressure, acceleration of gravity, and reference (e.g., standard) pressure and temperature for newly created projects.
25. Where do I find the Options.xml file?

The Options.xml file location is dependent on the installation drive and language of the operating system. You can find the system wide Options.xml file in the application data folder under %AllUsersProfile%. The string %AllUsersProfile% represents a language independent environment variable for the common profile used by all users of a computer. Simply type the string %AllUsersProfile% into the address field of Windows Explorer to change to the proper folder. The Options.xml file is in a hidden folder in the %AllUsersProfile% folder. The name of that folder is also dependent on the language of the operating system. You can determine the name of this folder for your particular system by inspecting the last folder name in the %AppData% environment variable. Within the hidden folder, you will find a Bryan Research & Engineering Inc folder that contains Options.xml. For example, consider the following which is typical of an English language system:

AllUsersProfile=C:\Documents and Settings\All Users
AppData = C:\Documents and Settings\SomeUserName\Application Data

For this system, Options.xml would be located in C:\Documents and Settings\All Users\Application Data\Bryan Research & Engineering Inc\ProMax3\Data. When modifying the Options.xml file, you must keep in mind that future releases of the program will supply new versions of Options.xml. Any changes made to Options.xml must be manually incorporated in future files. The ProMax installation program will create a backup of Options.xml to prevent overwriting your modifications.

26. Can I make the Options.xml file user specific?

To provide each user with their own Options.xml, copy the Options.xml from the standard location to %AppData%\Bryan Research & Engineering Inc\ProMax3\Data. Each user can then make their own changes to Options.xml independently of other users on the same system. This is typically useful on shared systems used by more than a single user (e.g., a university environment).

27. Where can I obtain more information on XML file structure?

See http://www.w3c.org/xml for information concerning XML. There are also many books published on XML available at virtually any bookstore containing computer related books.

28. What program do I use to edit Options.xml and other XML files?

Many XML editors are available for use. However, our configurable XML files for ProMax can be edited with Notepad if you do not have another editor.

29. How do I change the default or startup unit set for ProMax?

In Options.xml, change the text of the node //ProMax/UnitSets/Default to the name of the desired unit set.

30. How do I change the units on a particular property in one of the unit sets?

The units for a particular type of unit (e.g., length) are defined in the Options.xml file for each unit set available in ProMax. Simply locate the type of unit that is to be altered in the respective unit set. Change the text content of the XML node to the desired string. Note that unit strings in ProMax are case sensitive.

31. How do I add my own unit set to ProMax?

All unit sets are defined in the Options.xml file. To add a unit set, BR&E recommends that you copy and paste an entire existing unit set that is closest to the desired units. Change the name of the unit set to a name that does not conflict with an existing unit set and change the unit strings in the elements of the unit set to the desired values. You can make the new unit set the default by changing the text of the node //ProMax/UnitSets/Default to the name of the new set.

32. How do I configure ProMax to use A4 size paper?

In Options.xml, change the //ProMax/ReportOptions/Paper node text from “A” (letter) to “A4” (without quotes). You also will likely want to change the default Visio template from a letter size based template to an A4 size based template. This is accomplished by changing the //ProMax/ProjectTemplate node text to Project-A4.vst.

33. Can I change the content or order of the default set of properties that are displayed or reported with a stream?

Yes, these values are changed through Options.xml in the //ProMax/DisplayOptions/PStream/Properties and //ProMax/ReportOptions/PStream/Properties nodes, respectively. Simply order these items or add additional content as desired. Changes made in the Options.xml file affect newly created projects and projects that have not been customized for a specific property set.

34. Can I change the content or order of the process stream properties tooltip?

Change the entries in the //ProMax/DisplayOptions/Tooltips of Options.xml to the desired content.

User Interface Issues and Questions

35. The ProMax window will not restore from the taskbar after I minimize it; how can I bring it back?

This is a known issue with an interaction between Visio, ProMax, and Excel Add-Ins. To bring back the ProMax window:

  1. Click on the ProMax icon in the Taskbar, and move the mouse over the thumbnail ProMax (not Excel) window that should appear.
  2. Right-click on this window and select "Restore".
  3. If this doesn't work, open the Task Manager by either right-clicking on the taskbar and selecting "Start Task Manager" or pressing Ctl-Alt-Del and selecting "Start Task Manager".
  4. From the Applications tab, select the ProMax instance you would like to open.
  5. Press the "Switch To" button at the bottom of the page, or right-click on the instance and select "Switch To" from the dialog.
36. How do I reset my ProMax menus and toolbars and other settings to their original condition?

To restore the menus and toolbars to their original status, delete the files %AppData%\Bryan Research & Engineering Inc\ProMax3\Data\LCID\*.vsu from your system. The value LCID represents the locale identifier for your language and location. A value of 1033 signifies U.S. English. ProMax will reconstruct these files as needed.

37. I’ve accidentally closed one or more of my Visio stencils. How do I get the stencils back?

Using the Stencils (Visio 2002) or Shapes (Visio 2003) menu item located in the File menu, browse to the install location of the stencils (%ProgramFiles%\Bryan Research & Engineering Inc\ProMax3\Templates) and add all *.vss files as stencils. In Visio 2007 click the Shapes item in the File menu and the stencils appear in the menu to the right. Select the stencils to be added.”

38. Can some blocks have multiple connections on one point? Which ones?

Separators, mixers and distillation columns will allow multiple inlet streams to be attached to an inlet connection point.

39. Sometimes the block names are on top of the streams such that the block name can be read, and sometimes the stream “strikes through” the block name. What causes this?

Depending on the routing of a stream connected to a block, the location of the stream text or name can be obscured. You can easily move the location of a stream name by selecting the yellow diamond with the cursor and dragging the text to a new position. Obviously if you move the label, you must assume the responsibility for repositioning it in a location that is proper in the context of the drawing. For more complicated drawings, it may be advantageous to reduce the point size of the text associated with a block or stream to provide more room for drawing entities. Alternatively, you can right click on the block and use the “Shape->Bring to front” menu item to have a block name superimposed over a stream.

40. Can I import/export data from Excel into/from the program for calculation into a flowsheet?

To import or export data to and from Excel, you must first create an OLE embedded Excel Workbook within ProMax using the “Add Excel Workbook” in the ProMax menu. This Workbook is then saved within the structure of the ProMax pmx project file along with the remaining project data. Once this Workbook is added, you export or import data as follows:

  • Select the data cell that you wish to export or import.
  • Next, right click the cell and select the first item from the context menu that appears. The Excel Export/Import Utility box will open. This box will float over both ProMax and Excel. (This right clicking also allows access to dialogs that remove Import/Export links.)
  • Next, select the Excel cell(s) where you wish to place the data link.
  • Last, explicitly confirm the desired type of import or export and close the utility.

Most single value items can be either exported or imported depending on their context within a project. At this time, composition data from a stream can only be exported to Excel. Be sure to select enough Excel cells to capture all exported data, or truncation of latter data will occur.

Use the ProMax Solver under the Excel Tools menu to design and converge flowsheet data. Beware that the Excel Solver (ALT+T+V) is not linked to ProMax and will not cause the ProMax Engine to resolve the flowsheet.

41. Can I copy streams and/or flowsheets with their information to another stream or flowsheet?

Current or “green“ streams can be copied and pasted to the same flowsheet with specifications or current information intact. To copy a stream to a different flowsheet, you will have to Copy and Paste the composition and conditions. Simply copying and pasting blocks or a group of blocks from one flowsheet to another in the same or different Projects copies only the blocks and streams without any of the specifications. You may also Export a ProMax Project and then Append that Project to another Project. The Exporting and Appending feature in effect accomplishes the copy and paste with specifications intact. Among other uses, this procedure can be used to create templates of common processes such as dehydration, amine sweetening, refrigeration, etc. for appending to other Projects. See ProMax Help for detailed information on Exporting and Appending ProMax Projects.

42. How do I create my own process shapes?

You may create your own process shapes for all operations except multi-sided exchangers and distillation columns using the Shape Converter in the ProMax Property Stencil. In effect the Shape Converter allows you to convert an ordinary Visio shape into a ProMax block. The new block can be saved for future use. See ProMax Help for further information.

General Simulation Questions

43. How do I prevent hydrate and freeze-out checks in simulations where they are likely not to occur (e.g., amine systems)?

You can disable the simple hydrate and other freeze type checks from occurring within the streams and blocks of all flowsheets associated with an environment by unchecking the “Check Freeze Out” button on the Options page of the environment dialog. You may also adjust how close to freeze conditions you actually must be before a warning is issued by changing the temperature delta value. Disabling this check does not affect freeze out calculations in Analysis objects.

44. What is the propagation terminal? When would one use a propagation terminal?

The Propagation Terminal is used in a closed loop situation where no material is entering or exiting the system (e.g., refrigeration loop). It is used to prevent specified properties from propagating both forward and reverse in the closed loop.

45. How do I obtain a desired UA or Approach Temperature in a heat exchanger?

For simple cases the UA or Approach Temperature can be specified directly in a cross-exchanger. Note that this must be a cross-exchanger block because the UA, LMTD, and Approach Temperature specifications are not available for two single-sided exchangers linked by an Energy Stream. For more complicated configurations with interconnected cross exchangers and recycles, a simple solver can be used to find the value of duty or temperature in a cross exchanger to achieve the desired UA or Approach Temperature. See ProMax Help for detailed examples describing the setup of UA or Approach Temperature solvers.

46. Why is the RVP calculated in the ProMax Vapor Pressure Analysis listed with units of psig when my specification states psia?

Often the RVP is reported as “psia” although the way the test is performed the pressure is actually a gauge pressure. The D 323 – 99a standard says “Note 1--Because the external atmospheric pressure is counteracted by the atmospheric pressure initially present in the vapor chamber, the Reid vapor pressure is an absolute pressure at 37.8 C (100 F) in kilopascals (pounds-force per square inch).” However, a bourdon tube pressure gauge is used to measure the pressure so the reported pressure is actually in psig. That is confirmed by procedure 5B1.4 in the API Technical Data Book.

47. Where do I set a fixed or constant circulation rate in a recycle loop (e.g., in an amine unit or glycol dehydration unit)?

While there are many valid locations for this specification to be made, the most common location is usually in the outlet of the Make-Up/Blow-Down operation. For typical amine or glycol dehydration units, it is also legal to specify the circulation rate in any lean stream between the regenerator reboiler and the absorber.

48. Can a battery of scenarios or parametric study be run, in some automated way, on a given ProMax project?

Yes, the ProMax Scenario Tool, which is an add-in for Microsoft® Excel (2000 or greater), allows you to easily and automatically solve a number of ProMax projects with various conditions. Some examples of the use of the Scenario Tool might be 1) Perturbing inlet conditions and compositions, 2) Adjusting equipment specifications, or 3) Simulating historic plant data. Please refer to ProMax Help for detailed information on using the Scenario Tool.

49. How do I run ProMax from Excel?

ProMax can run as an in-process OLE automation server within any OLE automation client. A common use is to run ProMax within Excel to perform utility functions such as property calculation and flash calculation. At this time, the automation interfaces are undocumented. However, with some assistance from BR&E and the VBA object browser, an experienced VBA programmer can likely accomplish some fundamental tasks. Please contact BR&E for assistance with a particular project.

50. Can ProMax model a mole sieve?

The ProMax Property Stencil includes a Membrane Tool which is a block that simulates an asynchronous vapor phase separation. This simplified model operates irrespective of equipment geometry. The tool provides the ability to perform a separation based on fixed total area, or to solve for the area given desired separation constraints. Permeability data (selectivity) is dependent on the polymer employed and its thickness. Example values from patent literature are provided in the Edit Permeability dialog for your convenience, however, consult literature or vendor references for final designs. See ProMax Help for detailed information on the Membrane Tool.

Dehydration Specific Questions

51. Which property package should I use for glycol dehydration applications?

For glycol dehydration, you may use either the Peng-Robinson or SRK property package. ProMax contains the modeling technology to accurately predict dehydration and hydrocarbon solubility (including BTEX) in these systems using either package. This technology is inherited from PROSIM, which has a long published and proven history for accurately modeling these systems. If high amounts of CO2 or H2S are present, you may obtain slightly better solubility predictions if the Peng-Robinson Polar or SRK Polar packages are used. In most cases, using the polar versions of the package will provide identical results but will take longer to execute.

52. Which property package should I use for aqueous methanol applications?

When methanol is present in an aqueous system, you must use either the Peng-Robinson Polar or SRK Polar package. The standard Peng-Robinson and SRK packages will not accurately predict the VLE, VLLE, or hydrate suppression for these systems. ProMax includes improvements over PROSIM in modeling these systems, especially when high methanol to water molar ratios exist.

53. Do I need to set the weight percent glycol in the Make-Up/Blow-Down operation as in the amine unit simulation?

No, the glycol composition is determined by the regenerator performance. In an amine system, the ratio of amine to water is to be held constant resulting in different make-up rates for amine and water. The fact that two separate make-up flows are present in the amine system requires the additional specification to satisfy the extra degree of freedom. However, the make-up composition of glycol and amine must be specified either in the make-up stream or in the Make-Up/Blow-Down block “Makeup Bulk Composition” column. (A typical make-up composition for TEG is 99.9 wt % TEG and 0.1 wt % water). See ProMax help for details on specifying the Make-Up/Blow-Down.

Acid Gas Treating (Amine) Specific Questions

54. Which property package should I use for amine unit simulations?

To obtain accurate results for any amine application, the Property Package must be set to one of the electrolytic models. Amine Sweetening or Electrolytic ELR should be used for most applications. Either SRK or PR may be used for the vapor phase. Electrolytic Kent-Eisenberg calculates more quickly than the other models, but should be used for preliminary results only.

55. Which property package should I use for sour water stripping applications?

To obtain accurate results for sour water stripping applications, use Electrolytic ELR as the Property Package.

56. How do I model a liquid-liquid amine treater?

Set the absorber Flash Type to LLE and leave the Column Type parameter set to Equilibrium (TSWEET Kinetics does not apply to liquid treating). A liquid-liquid treater will rarely have more that 2 or 3 ideal stages.

57. How do I specify the weight percent amine in my amine unit simulation?

In an amine unit simulation, you must set the weight percent amine in the Make-Up/Blow-Down block dialog Process Data tab. The amine concentration is specified in the Target Outlet Composition column. Water is specified as 100% in the Makeup Bulk Composition column. Other components such as carbon dioxide and hydrogen sulfide should NOT be entered in this table. See ProMax help for further information on the Make-Up/Blow-Down block specifications.

58. I want to specify rich loading in my amine absorber. How can I make this specification?

Rich loading cannot be specified directly as in TSWEET. Rich loading may be achieved using a Simple Solver to manipulate a parameter such as lean amine circulation rate to achieve the desired rich loading. See ProMax Help and ProMax Examples for further information on using a Simple Solver to achieve a certain rich amine loading.

59. How do I specify the stripper reboiler steam rate?

A separate exchanger representing the steam condensation side must be set up and linked to the reboiler using an energy stream. Then the steam rate may be set directly or a Specifier may be used to achieve a desired lb steam per gallon amine circulation specification. See ProMax Help and Examples for further information.

60. Can I easily determine the Lean and/or Rich Amine Loading?

Yes, you can use an Amine Analysis in any aqueous liquid stream to determine the CO2 and H2S loading in gr/gal, scf/gal, and mol/mol. The Amine Analysis also calculates the Total Acid Gas Loading in mol/mol, the pH, and the Molarity.

61. Does ProMax report the pH of a stream?

Yes, either in the Amine Analysis (process stream Analysis tab), or in the stream Full Species Information. The Full Species Information is accessed by clicking the “Ionic Info…” button at bottom left of the stream Composition tab. The pH property is reported as p[H+].

62. Can ProMax predict the effects of acid addition on stripper performance?

Yes, the effects of adding acid to the amine solution to protonate the amine can be simulated. Although any of a number of acids (e.g. phosphoric, hydrochloric, acetic, sulfuric) may be used to protonate the amine and enhance stripping, phosphoric acid (H3PO4) is recommended in the ProMax simulation because equilibrium and plant data are available to verify results

63. Is it possible to model a stripper with a reclaimer?

To model an amine reclaimer, a portion of the lean amine from the reboiler is split off, heated to simulate the reclaimer, and a Divider is used to split off a specified amount of amine equivalent to the amount of degraded amine. The amount of degradation cannot be predicted by ProMax, but the reclaimer model can be used to determine the reclaimer duty and amount of required amine make-up. See the Simple DGA Sweetening Unit for an example utilizing a reclaimer on the stripper.

64. How can I model a single stage contactor for liquid-liquid treating (or simulate a static mixer) since the distillation column has a minimum of 2 stages?

There are two ways to model a single stage contactor: 1) three phase Separator, or 2) two ideal stage Column with the efficiency set to 1% for all components on one of the stages. The Column approach must be used if you want to model a single stage contactor with less than 100% efficiency.

Heat Exchanger Rating Questions

65. How do I access Exchanger Rating?

In the exchanger block dialog Process Data tab, click the Enable checkbox near the bottom. This will allow you to access to the Rating tab.

66. Why can I not rate my air cooled (fin fan) heat exchanger in ProMax?

To rate an air cooled heat exchanger in ProMax, you must connect the heat exchanger to another heat exchanger side that contains air as the process fluid. (Single-sided exchangers cannot be rated in ProMax.) Usually the inlet and outlet temperatures are specified for this air side and ProMax computes the flow rate from the required duty. If nitrogen and oxygen are not present in the environment for the flowsheet, you may wish to add another flowsheet that contains nitrogen and oxygen and connect a heat exchanger in this flowsheet to the air cooler through a cross flowsheet connector.

67. I am rating an exchanger, but the fluids are reversed on my specification sheet. Why?

Within the heat Exchanger Rating information, very top line under the “Tubes” item asks for the Service, and the options are Supply and Demand. If the Hot fluid is flowing through the tube side, select Supply. If the Cold fluid is going through the tubes, select Demand. This selection follows the Second law of Thermodynamics, that heat always flows from a higher temperature level to a lower temperature level.

Separator Sizing Questions

68. How do I access Separator Sizing?

In the Separator block dialog Process Data tab, click the checkbox next to “Include Separator Sizing”. This will allow access to the Sizing tab. (If the “Include Separator Sizing” parameter is not visible, scroll down to the end of the Process Data parameters.)

Reporting Questions

69.)  Why does my RTF output not work in WordPerfect or other RTF compatible programs?

ProMax requires version 1.7 of RTF. Most of these packages are only compatible with earlier versions of RTF. Microsoft provides a Word Viewer program that is freely available from the Internet if you do not have Microsoft Word.

70.)  I sent my RTF or Excel report to someone that does not have ProMax and the Report Navigator does not appear. Why?

The Report Navigator is software that is part of the ProMax package and is only available on systems that have a legal copy of ProMax installed. Installation and use of ProMax is governed by your license agreement.

71.)  I need to provide the client with a Heat and Material Balance of my process along with Equipment Specification Sheets for some of the pumps and heat exchangers. Is there a way to generate these from ProMax?
Yes, the User Defined Report tool, which is a Microsoft® Excel (2000 or greater) Add-In, allows you to create reports using existing templates, or to modify those templates to further customize the reports. This feature is useful for creating energy/material balance sheets and data or specification sheets for various equipment such as compressors, pumps, and exchangers. The User Defined Report can include any desired blocks, streams, or other objects in the Project, and the appearance can be completely customized to include colors, borders, logos, etc. The User Defined Report can be accessed through the ProMax Report dialog in ProMax 3.0, or it can be used as a stand-alone tool in Excel. A number of pre-defined report templates are available in the "AddOns\Excel\User Defined Report" Examples folder. Although the ProMax Help includes detailed information on used the Report Designer and Report Generator tools, BR&E support can assist you with creating a custom report design.